FieldBee Android Application FAQ

Author: Katalin
Dated: 20 May 2019

Is my phone compatible with the FieldBee app?

To work with the FieldBee tractor navigation app, you will need an Android smartphone or tablet with the following parameters:

  • Android OS: version 5.0 or higher
  • Display: 7’’ (inches) Resolution: 1280×800 pixels or higher
  • CPU: 4-core or more core (Qualcomm Snapdragon/Intel)
  • Memory: 2GB RAM or higher
  • Connectivity/Radios: Wi-Fi or 3G/LTE, Bluetooth

You can find a list of recommended devices here.

Was this helpful? Yes No
Suggest Edit

Become a partner


Request a quote


Suggest a feature

What new features would you like us to add to the FieldBee tractor navigation app?