Compatible devices

How to check if my phone is compatible with the FieldBee app

To work with the FieldBee app, you will need an Android device with the following parameters:

Minimum

  • Android: 5.1.1: Lollipop;
  • Processor: Qualcomm Snapdragon 632 MediaTek Helio P22
  • RAM: 4GB
  • 3G (WCDMA/UMTS/HSPA); 4G (LTE)
  • Connectivity/Radios: WiFi or 3G/LTE, Bluetooth.

Recommended

  • Android: 7.1: Nougat;
  • Processor: Qualcomm Snapdragon 845
    MediaTek Helio X30
  • RAM: 8GB
  • 3G (WCDMA/UMTS/HSPA); 4G (LTE)
  • Connectivity/Radios: WiFi or 3G/LTE, Bluetooth.

Here you can find a list of recommended devices and accessories compatible devices.

Can I connect the FieldBee app to another antenna, terminal or other systems?

It is possible to connect to the FieldBee app any antenna that has Bluetooth interface and receive NMEA messages. For that, you need to have active Premium app subscription

Although we can not guarantee the compatibility of your antenna with our application.

The FieldBee antenna was designed specifically to work well with the FieldBee app. You can find more information here.

Is it necessary to have a smartphone/tablet? Does another monitor work?

We highly recommend using the FieldBee app on your Android smartphone or tablet for Navigation. Those devices will help you to stay productive and omit additional trouble while you are driving in fields.
Leave a Reply

Your email address will not be published. Required fields are marked *